论坛

电路长期漂移较大

此问题尚无答案
All Replies
  • 秀才70分

    做了一个电路 采集模拟信号  范围±2V  电路长期漂移较大    30分钟漂移 30uV  把后面 连接的2.5V的上拉电阻去掉  漂移就控制在5uv 以内    但是这个电路必须要能支持 正负信号输入   望各位提供一些思路 

  • 进士5956分

    运放都有失调电压,OPA2333的Vos典型值在2uV,比OPA2188要小,建议您可以考虑用OPA233试试。OPA233 数据手册请参考这个链接:http://www.ti.com.cn/product/cn/opa2333

  • 秀才70分

    有比较的    去掉后面的上拉电阻   漂移就很小了    可以忽略不计     我感觉  应该是电路结构的问题   电路噪声不大   输入短路后  最大5uv  

    帮忙分析分析    那两个电阻 为什么不能加    也许不能在这个位置加     应该在哪里加     

    你们有更好的电路也欢迎推荐一下     

  • 进士5956分

    建议您可以通过TINA进行一些仿真参考。

  • 榜眼22540分

    在这种应用电路中一般都没有这个上拉电阻,你加的原因是什么?出于什么考虑?

    我自己这样觉着,没有验证,你可以试验一下

    因为运放的输入端是高阻,而输出端是低阻,如果有个上拉电阻,就会有电流通过REF2V5流过R7,R8,运放的Ro(一般几十欧姆至几百欧姆)到GND

    由于你的电阻阻值都不大,这个电流大概在几百uA,我觉着这个电流导致某些器件发热引起温漂

    如果将上拉电阻加大至几十k欧或100k欧,这个电流就会小很多,我想这个温漂就会小很多

    你可以试验验证一下

  • 秀才70分
    Signal.pdf
    非常感谢您的分析和解答
    是的一般这种差分电路是不加上拉的,但是实际输入信号的幅度绝对值最大±2V.由于ADC(ADS1256)只能处理正电压,所以我这里就统一都加了上拉,实现一个电压抬升.
      
    电阻小引起电流较大, 可能引起温升 , 这个我考虑到了 .  我把电阻值等比例增大100倍之后,有一点的改善不是太明显还是漂. 我觉得和电阻的值 关系不会太大 ,  我把电阻的值同比例增加了5倍.  
    后面的电路测试   都用 5.1k  10k 组合    
    后来 我把上拉电阻位置改到了  输入电阻R9和R13的后面  如图所示
    测量发现,问题依旧,漂移现象没有改变. 整个全差分电路,哪里都不能加上拉.只要加上拉.漂移立马出现   半小时 漂移在 30uv     这种漂移就是单纯由于温度的变化引起的吗?
    参考电源电路如图  
    原来OPA350的输出同时为ADC和各路上拉电阻提供参考,这里也改进一下     OPA350输出只为ADC提供参考    其他2.5V的上拉   专门加了一个缓冲放大器提供  如图:
    然后测试.还是没有改善,漂移依旧,还是没有找到问题在哪里 .也许和布局布线有一定的关系.我把文件传上来,大家看看  
  • 秀才70分
    4CH_CJKV_1.0_Release - 副本.rar

    也可能 和布局布线有一定关系     这是 PCB文件     帮忙分析分析  

  • 秀才70分
    Signal.pdf
    非常感谢您的分析和解答
    是的一般这种差分电路是不加上拉的,但是实际输入信号的幅度绝对值最大±2V.由于ADC(ADS1256)只能处理正电压,所以我这里就统一都加了上拉,实现一个电压抬升.


    电阻小引起电流较大, 可能引起温升 , 这个我考虑到了 .  我把电阻值等比例增大100倍之后,有一点的改善不是太明显还是漂. 我觉得和电阻的值 关系不会太大 ,  我把电阻的值同比例增加了5倍.  后面的电路测试   都用 5.1k  10k 组合    
    后来 我把上拉电阻位置改到了  输入电阻R9和R13的后面  如图所示
    测量发现,问题依旧,漂移现象没有改变. 整个全差分电路,哪里都不能加上拉.只要加上拉.漂移立马出现   半小时 漂移在 30uv     这种漂移就是单纯由于温度的变化引起的吗?
    参考电源电路如图  
    原来OPA350的输出同时为ADC和各路上拉电阻提供参考,这里也改进一下     OPA350输出只为ADC提供参考    其他2.5V的上拉   专门加了一个缓冲放大器提供  如图:


    然后测试.还是没有改善,漂移依旧,还是没有找到问题在哪里 .  完整的信号处理部分清看附件  
  • 状元66786分

    亲;以你描述,多半是PCB沿面漏电所至。首先建议清洗板子,然后烘干试试。后期;建议用地线包绕信号线以彻底解决问题。

  • 秀才70分

    谢谢    我测试一下

  • 秀才70分

    谢谢大家的解答和建议   经过测试  果然和板子脏污有一定关系    现在还是漂   不过经过几分钟之后就稳定了