UCC28700 低压启动不起来

UCC28700 低压启动不起来

此问题尚无答案
All Replies
  • 秀才190分

    各位好,我在用28700设计的一款5V 2A 的手机充电器,原理图在下面,

    设计比第一版的时候,输入滤波电容20UF,上图中R17为3K,没有加C6,85-265Vac输入,电源工作正常;但是改版后同样

    的参数调试时发现,如果CS引脚不加33pf的电容,85V-265V输入,电源输出电压不会超过2V,最终将R17改为910欧姆,

    并给CS引脚加一个33p的电容,这样电源在170-265v能正常输出,可带负载2.2A,但85-170时则输出不正常,这个很急,

    请帮忙及时分析下,谢谢。

     

     

     

  • 秀才245分

    以我调试 用UCC28700的经验来看,电源工作不正常,基本上都反映在VDD的电压上。估计变压器参数不太好,低压时,VDD不能维持。你自己用示波器看看先吧。

  • 秀才190分

    你好,VDD的电压我用示波器看过的,85-170V的时候,VDD上的电压波形是一8V到21V的锯齿波,的确不能稳定,

    但是同样的变压器,我未改版前的那块板子上是可以的,请帮忙分析下是不是还有别的原因?

  • 秀才245分

    你好,根据我用UCC28700的经验来看,电路中影响VDD稳定性的有几个部分的电路:

    1.变压器参数,尤其是辅助绕组的匝比;

    2.RCD吸收电路,尖峰吸收不好,容易造成VDD过压烧,但是钳位太厉害,就可能造成辅助绕组对VDD充电不够,以至于IC无法正常工作;

    3.MOSFET的驱动也有影响,但是那部分一般都是标准接法,你可以更换个MOSFET试试;

    另外你用示波器看VDD时,最好同时看看DRV输出,看看是完全不能建立VDD,还是带负载后不能维持。

    我想要最好的解决方案还是增加辅助绕组的匝数,估计你之前的变压器参数就很临界。

    希望你早日解决问题,把结果分享一下哈……

  • 秀才245分

    这位兄弟,才发现你MOFET驱动电路还真的有点问题,G和S之间可以不跨接电阻吗?没见过……

    你接一个10K电阻试试,如果还不行,可以试试自己搭一个加速关断的简单电路。

    MOSFET的关断响应速度之间影响反激电压的高低呀……

  • 秀才190分

    陈大哥,谢谢热心回答,是和我下图一样,在这个位置接个10K的电阻吗?

    还有我有个问题想问,加这个电阻,关断MOS的关断速度会快,但S接的是电流检测电阻R18,

    这个10K电阻会影响芯片电流检测的信号吗?我入行不久,请指教下,谢谢。

  • 秀才245分

    是的,那个地方应该接一个电阻,通常是一端直接接地,接在那里也没什么问题,那点电流根本不影响R18的采样精度。

    你可以用WEBEBCH设计一下嘛,看看生成的电路和你的有什么差异。

    TI的官网有5V2A的成熟案例也可以下下来看看啥

  • 秀才355分

    这位兄弟,能描述一下你改板前后除了输入滤波电容和R17,还进行了哪些修改?(Layout或者变压器改了吗)

    因为你原来的电路工作时正常的,改了以后不正常了,那分析问题的思路就在于你到底两个板子有什么不一样。

    时间关系,我也没有计算你电路上元器件的参数,建议你可以参考一下我们的参考设计,或者用我们的WEBENCH在线设计工具设计一下。

    以下是5V/2A参考设计的连接:

    http://www.ti.com.cn/tool/cn/pmp4351

    http://www.ti.com.cn/tool/cn/pmp8286

  • 秀才355分

    根据你之前的描述,建议你可以观察下芯片CS引脚上的波形,看看是否有比较大的振荡或尖峰,测量的时候一定要注意尽量减小示波器探头上地和探针的回路(这样才能看到真实的波形)。

  • 榜眼22570分

    user guide中接10k电阻的地方和你的不一样,你可以参考下

  • 秀才190分

    之前板子的尺寸50x50的,现在改版成40X40.所以Layout变了,变压器没变,参数我也和WEBENCH上的设计比对了,没有多大区别,MOSFET的G和S极跨接10K电阻的方法我也试了不行,

  • 秀才245分

    我始终觉得还是变压器那里出了问题,你把变压器参数贴出来看看,或者用你之前的变压器和现在的变压器互换试试。

  • 秀才190分

    不好意思,出差了两天,变压器参数如下:

    先原边,在辅助绕组,最后输出绕组;原边感量Lp = 440UH,漏感<20uh。

    新做的变压器换到原来板子功能OK的,应该不是变压器的问题。

  • 秀才245分

    你试着对换两个变压器了吗?如果参数临界,多半圈和少半圈就是差异。

    还有就是RCD吸收那里,你试试将吸收减弱些。

  • 举人1555分

    增大VDD电容试试