5509A 如何使用dsplib 3.00

5509A 如何使用dsplib 3.00

此问题尚无答案
All Replies
  • 秀才41分

    您好:

          我在CCS5.2的编译环境下,编译5509A,在调用的dsplib3.00时,出现

    "C:\c55_lp\c55_dsplib_3.00\lib\55xdspx_r3.lib<fir2.obj>" specifies "C55x CPU
    Rev 3.x", which is not compatible with "C55x CPU Rev 2.x" specified in a
    previous file or on the command line

    这应该是DSP的架构较老,如何在该5509A,使用dsplib3.00.如果在silicon version选择5505或者5515编译能够通过。

  • 状元53656分

    用老的版本就好了。

    http://www.ti.com/litv/zip/sprc100

    http://processors.wiki.ti.com/index.php/C55x_DSPLIB_FAQ

    http://processors.wiki.ti.com/index.php/Main_Page

    Think Over Before Asking.

    http://www.catb.org/~esr/faqs/smart-questions.html#goal

  • 秀才41分

    您好,我没有安装CCS3.3,当前版本是CCS5.2,刚才您给我发的那个链接是dsplib3.00.我当前正在使用的库也是从这儿下载的,http://www.ti.com/litv/zip/sprc100

    如果在5509A上使用dsplib的库函数,必须在CCS3.3下编译吗?

    如果想在CCS5.2下编译,也没有找到老版本库函数的链接。

    Q: How can I rebuild the DSPLIB v2.40.00 library for a newer CPU rev. 3.x?

    在这里面只提到了从2.4编译到3.0的方法,没有说明如何从3.0X编译回2.4。



  • 秀才41分

    您好,如果我最后必须调用dsplib库函数的话,我只能安装ccs3.3,然后使用CCS3.3自带的dsplib 2.40。没有其他的解决办法了吗?麻烦大神指导一下

  • 状元124627分

    可以按照FAQ里的方法反过来试试,把Blt55x_r3.bat里的-vcpu:3.3改成-vcpu:2.2试试。

  • 状元53656分
    sprc100(TMS320C55x DSP Library2.4).zip

    sprc100(TMS320C55x DSP Library2.4)

    老版本也可以在CCS5.2上用的吧。只是库而已。

    http://processors.wiki.ti.com/index.php/Main_Page

    Think Over Before Asking.

    http://www.catb.org/~esr/faqs/smart-questions.html#goal

  • 秀才41分

    谢谢,我的网上没有找到这个library的链接,非常感谢,我先测试一下,有问题再向您请教!