参考下面网址

http://processors.wiki.ti.com/index.php/Processor_Training:_Multimedia#Encode_Pipeline

尝试一些例子

 

kmssink:

  target #  gst-launch-1.0 playbin uri=file:///<path_to_file> video-sink=kmssink audio-sink=alsasink

上面这条命令可以

 

但是下面这条出现错误,错误提示 Internal data flow error

Capture and Display Fullscreen

  target #  gst-launch-1.0 v4l2src device=/dev/video1 num-buffers=1000 io-mode=4 ! 'video/x-raw, \

format=(string)YUY2, width=(int)1280, height=(int)720' ! vpe num-input-buffers=8 ! queue ! kmssink

 

cmd line display bellow:

root@am57xx-evm:/mnt#

root@am57xx-evm:/mnt#

root@am57xx-evm:/mnt#

 io-mode=4 ! 'video/x-raw, \unch-1.0 v4l2src device=/dev/video1 num-buffers=1000

 ! queue ! kmssink2, width=(int)1280, height=(int)720' ! vpe num-input-buffers=8

Setting pipeline to PAUSED ...

Pipeline is live and does not need PREROLL ...

Setting pipeline to PLAYING ...

New clock: GstSystemClock

[ 6171.709015] contiguous chunk is too small 4096/1843200 b

ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Internal data flow error.

Additional debug info:

../../../../gstreamer-1.6.3/libs/gst/base/gstbasesrc.c(2943): gst_base_src_loop (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:

streaming task paused, reason error (-5)

Execution ended after 0:00:01.818353713

Setting pipeline to PAUSED ...

Setting pipeline to READY ...

Setting pipeline to NULL ...

Freeing pipeline ...

am57xx 开发板上 如何解决这个问题